www.whkt.net > 哪个版本CEntos带gCC

哪个版本CEntos带gCC

ubuntu 8.04有3.3/3.4/4.1/4.28.10和9.04有3.4/4.1/4.29.10只有4.1/4.2/4.3ubuntu没有你要的3.2.RedHat 9有3.2.你可以在fc和centos里边找找,redhat系的,应该也有吧.别的发行版不知道.感觉你还是找源码自己编译吧,虽然有点麻烦.

我只用过Ubuntu,都带其他的不清楚,但这些东西很常用,主流的发行版应该都带吧

CentOS作为服务器系统,追求的是稳定性和高性能,运行其上的软件自然不会同步得那么实时.普通软件,找到合适的YUM仓库就能顺利解决依赖完成更新. 但是对于GCC这种底层应用来讲,涉及到的依赖非常多.更新超复杂,且不建议在生

应该些依赖没 执行命令安装:sudo yum install gcc

gcc --version查看一下即可;与此同时,你问题的方式就有问题,linux2.6.2是内核版本号而已,他跟gcc完全没有关系,他们是独立的两个东东,只是说ubuntu或者cenot/rhel把他们整合到一起去了而已;

你好!是的 自带gcc 你输入gcc --help 会显示gcc版本 用法等信息我的回答你还满意吗~~

linux各个版本的核心操作和管理基本上都是差不多的.像redhat,centos,ubuntu,arch等等,会了一种,换另外一种系统,稍微熟悉一下就可以了.像gcc编程之类的,跟发行版没关系,都是一样的.初学一般用rhel,centos ,

先用yum remove gcc把最新的卸载了,然后去网上搜索并下载你要安装的低版本gcc的源码包,自己解压然后编译安装.

那取决于.你要用gcc干什么?比如编译c语言源代码,比如有个源代码,你把他命名为123.c 然后编译,终端输入 gcc 123.c 之后会出现一个编译好的a.out 再执行编译好的文件就可以了.

我使用6.5点版本,gcc还是4.4.2版本不支持.后面升级到gcc4.8.5支持大部分c11特性.根据官方 的说法需要gcc4.7以上.

友情链接:xmjp.net | kcjf.net | hyfm.net | zdly.net | famurui.com | 网站地图

All rights reserved Powered by www.whkt.net

copyright ©right 2010-2021。
www.whkt.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com